"LIBPF is not yet activated on this computer" error when launching a model

Continuing the discussion from Problem with "Testing your LIBPF™ SDK install":

What happens here is that you installed one of the public demos, which are activated for one site identifier, whereas the SDK you have received produces binaries that are activated for another site identifier (the site identifier is an alphanumerical code assigned to every customer).

FYI, on OS X the currently activated site identifier is stored as the SiteId key in a plist (property list) file. You can use the builtin plutil tool to look it up:

plutil -p /Library/Preferences/com.libpf.LIBPF.plist | grep SiteId

This should print something like:

  "1-0.SiteId" => "com.example_1.0"

The SDK you have received is activated for it.unige_1.0, which I guess is different from what you’ll get above.

The easiest thing you can do to solve this issue is perform the automatic activation (menu Settings → Activate) from one of the packages specific to your own site identifier, that you have received together with the SDK.

In other words:

  1. close the LIBPF user interface
  2. remove the inorganics demo you have installed (including unmounting the associated UIPF disk)
  3. mount the dmg you received with the mcfcccs model
  4. open the LIBPF user interface for that model
  5. launch activation (menu Settings → Activate) from there.

Now plutil should print this:

"1-0.SiteId" => "it.unige_1.0"

and the models developed with the SDK should run. So go back to this step:

and try again !

OK now it works, i go back to the step :
cd …/bin
./Qpepper new SaltPepper
and now there are no problems.
But When i come back to Qt creator and i build the project there is another problem as i show you in this image:

The problem is " xCode not set up properly . You may need to confirm the license agreement by running /usr/bin/xcodebuild.