Problem with "Testing your LIBPF™ SDK install"


#1

I’ve just followed the procedures to undestand if the installation of LIBPF™ SDK on OS X was successful.

cd ~/Desktop
cd LIBPF_SDK_osx_1.0.2222/
cd pepper
b2 install-bin
-bash: b2: command not found

When I insert “b2 install-bin” on the terminal the answer of the system is “-bash: b2: command not found”.
What is the problem?


#2

Hi Marco b2 is the command to launch Boost.Build. If you followed the “HOWTO install a LIBPF SDK for OS X” guide, you should have installed that where it says “Once Homebrew is installed, type these commands in a terminal to install the required 3rd party software tools and libraries: …

Did you execute those 4 commands ? Did they return any error ?


#3

Hi
I’ve just installed the commands :

brew doctor
brew install --c++11 boost
brew install homebrew/science/suite-sparse
brew install boost-build jsoncpp libmxml swig xz

this is the answer of the terminal:

MBP-di-Marco:~ marcocescocasanova$ brew doctor

Please note that these warnings are just used to help the Homebrew maintainers

with debugging if you file an issue. If everything you use Homebrew for is

working fine: please don't worry and just ignore them. Thanks!



Warning: A newer Command Line Tools release is available.

Update them from Software Update in the App Store.



Warning: Xcode is installed to a directory with a space in the name.

This will cause some formulae to fail to build.

MBP-di-Marco:~ marcocescocasanova$ brew install --c++11 boost

==> Downloading https://downloads.sourceforge.net/project/boost/boost/1.58.0/boo

Already downloaded: /Library/Caches/Homebrew/boost-1.58.0.tar.bz2

==> ./bootstrap.sh --prefix=/usr/local/Cellar/boost/1.58.0 --libdir=/usr/local/C

==> ./b2 headers

==> ./b2 --prefix=/usr/local/Cellar/boost/1.58.0 --libdir=/usr/local/Cellar/boos

🍺  /usr/local/Cellar/boost/1.58.0: 10718 files, 485M, built in 21.8 minutes

MBP-di-Marco:~ marcocescocasanova$ brew install homebrew/science/suite-sparse

==> Tapping homebrew/science

Cloning into '/usr/local/Library/Taps/homebrew/homebrew-science'...

remote: Counting objects: 558, done.

remote: Compressing objects: 100% (556/556), done.

remote: Total 558 (delta 2), reused 75 (delta 1), pack-reused 0

Receiving objects: 100% (558/558), 442.76 KiB | 0 bytes/s, done.

Resolving deltas: 100% (2/2), done.

Checking connectivity... done.

Tapped 551 formulae (578 files, 2,9M)

==> Installing suite-sparse from homebrew/homebrew-science

==> Installing dependencies for homebrew/science/suite-sparse: tbb

==> Installing homebrew/science/suite-sparse dependency: tbb

==> Downloading https://homebrew.bintray.com/bottles/tbb-4.3-20150611.yosemite.b

######################################################################## 100,0%

==> Pouring tbb-4.3-20150611.yosemite.bottle.tar.gz

🍺  /usr/local/Cellar/tbb/4.3-20150611: 106 files, 1,9M

==> Installing homebrew/science/suite-sparse

==> Downloading https://homebrew.bintray.com/bottles-science/suite-sparse-4.4.4_

######################################################################## 100,0%

==> Pouring suite-sparse-4.4.4_1.yosemite.bottle.tar.gz

🍺  /usr/local/Cellar/suite-sparse/4.4.4_1: 145 files, 10M

MBP-di-Marco:~ marcocescocasanova$ brew install boost-build jsoncpp libmxml swig xz

==> Downloading https://homebrew.bintray.com/bottles/boost-build-2014.10.yosemit

######################################################################## 100,0%

==> Pouring boost-build-2014.10.yosemite.bottle.tar.gz

🍺  /usr/local/Cellar/boost-build/2014.10: 278 files, 3,1M

==> Downloading https://homebrew.bintray.com/bottles/jsoncpp-0.10.5.yosemite.bot

######################################################################## 100,0%

==> Pouring jsoncpp-0.10.5.yosemite.bottle.tar.gz

🍺  /usr/local/Cellar/jsoncpp/0.10.5: 18 files, 676K

==> Downloading https://homebrew.bintray.com/bottles/libmxml-2.9.yosemite.bottle

######################################################################## 100,0%

==> Pouring libmxml-2.9.yosemite.bottle.tar.gz

🍺  /usr/local/Cellar/libmxml/2.9: 25 files, 576K

==> Installing dependencies for swig: pcre

==> Installing swig dependency: pcre

==> Downloading https://homebrew.bintray.com/bottles/pcre-8.37.yosemite.bottle.t

######################################################################## 100,0%

==> Pouring pcre-8.37.yosemite.bottle.tar.gz

🍺  /usr/local/Cellar/pcre/8.37: 146 files, 5,9M

==> Installing swig

==> Downloading https://homebrew.bintray.com/bottles/swig-3.0.7.yosemite.bottle.

######################################################################## 100,0%

==> Pouring swig-3.0.7.yosemite.bottle.tar.gz

🍺  /usr/local/Cellar/swig/3.0.7: 729 files, 7,1M

==> Downloading https://homebrew.bintray.com/bottles/xz-5.2.1.yosemite.bottle.ta

######################################################################## 100,0%

==> Pouring xz-5.2.1.yosemite.bottle.tar.gz

🍺  /usr/local/Cellar/xz/5.2.1: 59 files, 1,7M

i think that there aren’t problem with this.
Then i proceeded with this procedure:

Open a terminal, then move to the LIBPF SDK location, for example:

cd ~/Desktop
cd LIBPF_sdk

enter the “pepper” sub-directory and compile the SaltPepper example with:

cd pepper
b2 install-bin

move to the bin directory and run it with:

cd ../bin
./Qpepper new SaltPepper

The answer of terminal now is this:

MBP-di-Marco:~ marcocescocasanova$ cd ~/Desktop
MBP-di-Marco:Desktop marcocescocasanova$ cd LIBPF_SDK_osx_1.0.2222
MBP-di-Marco:LIBPF_SDK_osx_1.0.2222 marcocescocasanova$ cd pepper
MBP-di-Marco:pepper marcocescocasanova$ b2 install-bin
warning: No toolsets are configured.
warning: Configuring default toolset "darwin".
warning: If the default is wrong, your build may not work correctly.
warning: Use the "toolset=xxxxx" option to override our guess.
warning: For more configuration options, please consult
warning: http://boost.org/boost-build2/doc/html/bbv2/advanced/configuration.html
...found 144 targets...
...updating 9 targets...
common.mkdir ../bin
common.mkdir ../bin/pepper
common.mkdir ../bin/pepper/darwin-4.2.1
common.mkdir ../bin/pepper/darwin-4.2.1/debug
common.mkdir ../bin/pepper/darwin-4.2.1/debug/src
darwin.compile.c++ ../bin/pepper/darwin-4.2.1/debug/src/SaltPepperDriver.o
darwin.compile.c++ ../bin/pepper/darwin-4.2.1/debug/src/SaltPepper.o
darwin.compile.c++ ../bin/pepper/darwin-4.2.1/debug/main.o
darwin.link ../bin/Qpepper
ld: warning: direct access in _main to global weak symbol std::__1::char_traits<char>::eq(char, char) means the weak symbol cannot be overridden at runtime. This was likely caused by different translation units being compiled with different visibility settings.
...updated 9 targets...
MBP-di-Marco:pepper marcocescocasanova$ cd ../bin
MBP-di-Marco:bin marcocescocasanova$ ./Qpepper new SaltPepper
LIBPF is not yet activated on this computer.
Please launch the libpf_activation application to perform the automatic, online activation.

If you prefer the manual activation procedure, relaunch the kernel as root (i.e. with administrative privileges), then follow the instructions.

Why he say that LIBPF is not activated on my computer??


"LIBPF is not yet activated on this computer" error when launching a model
#4

Congrats ! you’re going forward fast. You installed successfully the homebrew package management and the required 3rd party software tools and libraries. Compile & link from the command line works too, but now you’re now stuck with activation.

According to the HOWTO install a LIBPF SDK for OS X, “To run your models section”, to run the developed models you also need to activate LIBPF™.

The easy way is to install one of the LIBPF™ demos, launch the User Interface and perform the automatic activation (menu Settings -> Activate). For more details see the LIBPF™ Activation Guide in the user manuals page.


"xCode not set up properly. You may need to confirm the license agreement by running /usr/bin/xcodebuild" error
#5

It’s strange because i’ve just opened one of the Demos, then from the “settings – > activate” the system had told me that LIBPF was active, i repeat the same method of before but the answer by the terminal is always the same :
LIBPF is not yet activated on this computer.
Please launch the libpf_activation application to perform the automatic, online activation.

I’m trying to send you an image but the size is too big, i’ve send the screenshot on your e-mail.


"LIBPF is not yet activated on this computer" error when launching a model
#6

Aww ! my mistake ! the SDK you are using produces binaries that are activated for another site identifier than the one used in the public demos. I should have given you a different advice !

I’ll start now a new thread using the “Reply as New Topic” button (that pops up when you hover to the right of the post) because your new problem is unrelated to this thread.


#7

ok, i’ve received both of the e-mail, but it’s not clear what i have to do.
I put this code on the terminal

plutil -p /Library/Preferences/com.libpf.LIBPF.plist | grep SiteId

and, as you said, it answer me

  "1-0.SiteId" => "com.example_1.0"

and then? I’ve to proceed with the same commands of before?


#8

Let’s continue this over to the “LIBPF is not yet activated on this computer” error when launching a model thread …